Page 1 of 1

Asterisk 1.6 and 1.8 compatibility

PostPosted: Fri Jan 14, 2011 10:13 am
by TTTSupport
ADAT is free for anyone to use. It was originally developed for (personal) use with Asterisk 1.4. It appears there are some compatiblity issues with Asterisk 1.6 and 1.8 that need to be sorted out. As Asterisk 1.4 is still our preferred production platform, there is no real business case for 1.6/1.8 compatiblity at the moment.

Also, as there is no funding for ADAT and we are lucky to have plenty of other work, ADAT is not getting the attention it deserves.
We will keep developing ADAT whenever we find the time, but other (paid) projects are more likely to get higher priorities.

If we can raise bounties for ADAT development we can make quicker progress. If you have any problems that need fixing or require additional features please help us by funding ADAT development. You can contribute to this bounty by donating money: https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=CWWW86R2KN2UG

The bounty to be raised is 1000 USD.

Re: Asterisk 1.6 and 1.8 compatibility

PostPosted: Mon Mar 14, 2011 12:05 pm
by TTTSupport
We have released a new version last Friday. Please download (http://www.tttelecom.nl/index.php/en/component/docman/doc_details/6-adat-r2-0790) and test it. It should work on 1.8 and 1.6, but you may experience missing callerid in the ADAT popup... This will be investigated/solved soon.

ADAT v 0.7.9.0 (Beta release) 2011-03-03
============================= ==========
- Improved registry settings. Now all registry settings moved to user-specific context.
- Updated Asterisk.net library to latest version. Solved some issues concerning this version.
- Added support for connecting to Asterisk Servers running version 1.8 and 1.6.
- Added tooltips in ADAT settings window for easy configuration.
- Added more options in configuring callto: links

Please report back your findings regarding the new 1.8 compatibility.

Re: Asterisk 1.6 and 1.8 compatibility

PostPosted: Fri Dec 23, 2011 6:09 pm
by TTTSupport
ADAT R2 v0.7.12 should now work better with all versions of Asterisk! Please download an test it: http://www.tttelecom.nl/index.php/en/component/docman/doc_details/6-adat-r2-07120

Re: Asterisk 1.6 and 1.8 compatibility

PostPosted: Wed Feb 15, 2012 12:59 pm
by TTTSupport
The asterisk 1.6/1.8 compatibility bounty is now considered solved/closed.